Notice about Firmware Update for 28-75mm A036SF for Mac OS High Sierra Users

Dear users and potential purchasers of Tamron interchangeable lenses.

In regards to the recently released 28-75mm A036SF firmware update, unfortunately the installer program is not compatible with Mac OS 10.13 High Sierra at this moment.

For customers running Mac OS 10.13 High Sierra or higher your best option is to source a computer running compatible software or contact your local retailer to see if they are able to perform the update for you.

However, if neither of these options is available to you then please contact your local distributor through the ‘Warranties and Repairs’ link below.

2018-07-18T04:53:34+00:00